Add hyperlinkimage column to existing list - NullReferenceException

Apr 23, 2012 at 4:48 PM

I've been able to successfully use this column type on a new list, but when I add this to an existing list (that was originally created by an import from an Excel spreadsheet), I get the following exception when I attempt to view/edit an item:

System.NullReferenceException: Object reference not set to an instance of an object.   
 at KWS.SharePoint.WebControls.ImageHyperlinkFieldControl.CreateChildControls()    
 at System.Web.UI.Control.EnsureChildControls()    
 at Microsoft.SharePoint.WebControls.BaseFieldControl.OnLoad(EventArgs e)    
 at Microsoft.SharePoint.WebControls.UrlField.OnLoad(EventArgs e)    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Any ideas?

 

 

Sep 7, 2012 at 10:59 AM

Hi, I've got the same error.

A look into the Log shows me also this message before:

Template Discovery/InitScriptData: cannot get user profile, no UserProfileApplicationProxy exists in the current context

Is this a requirement of this solution?

Greetings